Recon-ng เป็นเครื่องมือสำหรับการทำ Reconnaissance ใน part ของการทำ pentest ซึ่งแต่ก่อนสามารถใช้งานได้ใน Kali ได้เลย แต่หลังจากที่เริ่มเปลี่ยนมาเป็น Kali Rolling-edition (2016.2) ก็มีปัญหาเพราะเรื่องของการขาด package สำคัญบางส่วนที่จำเป็นต้องใช้ใน Recon-ng เอง ซึ่งทำให้เมื่อเวลาเปิด Recon-ng ขึ้นมา มักจะเจอปัญหาว่า

ซึ่งการที่ module บางส่วนถูก disable เพราะเนื่องด้วยความที่ไม่มี package บางส่วนที่ module ต้องการนั่นเอง โดยเราสามารถแก้ไขได้ โดยทำตามนี้

1. Download Source ของ Recon-ng ลงมา

2. ติดตั้ง package ที่เป็น Prerequisite  ของ Recon-ng

3. ติดตั้ง Dependency package ที่อยู่ใน list ของ Recon-ng REQUIREMENT

4. ทดสอบใช้งานอีกครั้ง